View |
Constructs a new ViewOrientation3D using the input eye position, up and forward directions.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters

Exception | Condition |
---|---|
ArgumentException | One or both of the input vectors cannot be normalized. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | upDirection has zero length. -or- forwardDirection has zero length. |
ArgumentsInconsistentException | The vectors upDirection and forwardDirection are not perpendicular. |