IsEntryConsistentWithScheme Method


Checks whether an entry can be added to the scheme or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public EntryAndSchemeConsistency IsEntryConsistentWithScheme(
	ColorFillSchemeEntry entry
)
Visual Basic
Public Function IsEntryConsistentWithScheme ( _
	entry As ColorFillSchemeEntry _
) As EntryAndSchemeConsistency
Visual C++
public:
EntryAndSchemeConsistency IsEntryConsistentWithScheme(
	ColorFillSchemeEntry^ entry
)

Parameters

entry
Type: Autodesk.Revit.DBColorFillSchemeEntry
The entry to check.

Return Value

The state of entry and scheme consistency.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also