AddGridLine Method


Add a grid line to the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CurtainGridLine AddGridLine(
	bool isUGridLine,
	XYZ position,
	bool oneSegmentOnly
)
Visual Basic
Public Function AddGridLine ( _
	isUGridLine As Boolean, _
	position As XYZ, _
	oneSegmentOnly As Boolean _
) As CurtainGridLine
Visual C++
public:
CurtainGridLine^ AddGridLine(
	bool isUGridLine, 
	XYZ^ position, 
	bool oneSegmentOnly
)

Parameters

isUGridLine
Type: SystemBoolean
If true, a U-direction grid line will be added. Otherwise, a V-direction grid line will be added.
position
Type: Autodesk.Revit.DBXYZ
The position of the grid line.
oneSegmentOnly
Type: SystemBoolean
If it is true, only one segment is added. Otherwise, all segments will be added for the grid line.

Return Value

The created grid line is returned if the operation is successful. Otherwise, a null reference (Nothing in Visual Basic) is returned.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown if the position for the grid line is out of range.

See Also