AddGridLine Method


Curtain Grid Add Grid Line Method

Add a grid line to the curtain grid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CurtainGridLine AddGridLine(
	bool isUGridLine,
	XYZ position,
	bool oneSegmentOnly
)

Parameters

isUGridLine Boolean
If true, a U-direction grid line will be added. Otherwise, a V-direction grid line will be added.
position XYZ
The position of the grid line.
oneSegmentOnly Boolean
If it is true, only one segment is added. Otherwise, all segments will be added for the grid line.

Return Value

CurtainGridLine
The created grid line is returned if the operation is successful. Otherwise, is returned.
Exceptions
Exception Condition
InvalidOperationException Thrown if the position for the grid line is out of range.
See Also