Creates a new point cloud filter based upon planar boundaries.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- planes
- Type: System.Collections.GenericIListPlane
All planes used for filtering; positive direction of the normal should point inside the volume of interest.
- exactPlaneCount
- Type: SystemInt32
This value represents the number of planes (taken in order of their addition) which will be used for exact filtering of individual points. Other planes in the filter will be used for faster, but inexact filtering based on cells.
Return Value
Filter object; can be used to get representative set of cloud points passing through the filter.Remarks
The filter will check whether a point is located on the "positive" side of each plane, as indicated by the positive direction of the plane normal. Therefore, such filter implicitly defines a volume, which is the intersection of the positive half-spaces corresponding to all the planes. This volume does not have to be closed, but it will always be convex.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |