CheckConstructionSetElement Method


Checks that the construction set ElementId is acceptable.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public bool CheckConstructionSetElement(
	ElementId constructionSetElementId
)
Visual Basic
Public Function CheckConstructionSetElement ( _
	constructionSetElementId As ElementId _
) As Boolean
Visual C++
public:
bool CheckConstructionSetElement(
	ElementId^ constructionSetElementId
)

Parameters

constructionSetElementId
Type: Autodesk.Revit.DBElementId
The construction set ElementId to be checked.

Return Value

True if the construction set ElementId is a valid construction set element, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also