CheckConstructionSetElement Method


Energy Data Settings Check Construction Set Element Method

Checks that the construction set ElementId is acceptable.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CheckConstructionSetElement(
	ElementId constructionSetElementId
)

Parameters

constructionSetElementId ElementId
The construction set ElementId to be checked.

Return Value

Boolean
True if the construction set ElementId is a valid construction set element, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also