SetExternalItems Method


Transferring Project Standards Event Args Set External Items Method

Sets the collection of externally added items which should be shown in the Transfer Project Standards dialog as options.

Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetExternalItems(
	IDictionary<Guid, string> externalItems
)

Parameters

externalItems IDictionary Guid , String
The external items which are displayed in the Transfer Project Standards UI. GUIDvalue is used to identify the external item string.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The externally added items that the user opted to transfer will be reported in the args to the TransferredProjectStandards event.
See Also