Instantiates a SketchEditScope object.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document for which this SketchEditScope is going to be used.
- transactionName
- Type: SystemString
The name that will appear in the Undo menu in Revit after the SketchEditScope is successfully committed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | document is not a primary document, it is a linked document. -or- document is not a project document. -or- transactionName is an empty string. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |