SketchEditScope Constructor


Sketch Edit Scope Constructor

Instantiates a SketchEditScope object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SketchEditScope(
	Document document,
	string transactionName
)

Parameters

document Document
The document for which this SketchEditScope is going to be used.
transactionName String
The name that will appear in the Undo menu in Revit after the SketchEditScope is successfully committed.
Exceptions
Exception Condition
ArgumentException document is not a primary document, it is a linked document. -or- document is not a project document. -or- transactionName is an empty string.
ArgumentNullException A non-optional argument was null
See Also