IsolateCategoryTemporary Method


Set one category to be temporarily isolated in the view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void IsolateCategoryTemporary(
	ElementId elementId
)
Visual Basic
Public Sub IsolateCategoryTemporary ( _
	elementId As ElementId _
)
Visual C++
public:
void IsolateCategoryTemporary(
	ElementId^ elementId
)

Parameters

elementId
Type: Autodesk.Revit.DBElementId
Id of category to be isolated.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException elementId does not correspond to a Category.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also