SetPosition Method


Sets the position for this bending detail relative to its view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public static void SetPosition(
	Element bendingDetail,
	XYZ position
)
Visual Basic
Public Shared Sub SetPosition ( _
	bendingDetail As Element, _
	position As XYZ _
)
Visual C++
public:
static void SetPosition(
	Element^ bendingDetail, 
	XYZ^ position
)

Parameters

bendingDetail
Type: Autodesk.Revit.DBElement
The bending detail for which we want to get the position.
position
Type: Autodesk.Revit.DBXYZ
The new position for this bending detail relative to its view.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also