Creates an empty analysis results primitive associated with a reference.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- reference
- Type: Autodesk.Revit.DBReference
Reference pointing to the curve or face to be associated with the primitive
Return Value
Unique index of primitive for future referencesRemarks
There can be multiple primitives associated with one reference, normally they would be shown with different results. However this is justified only if they have different sets of domain points. Otherwise one primitive can be used to display values for different results.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | reference points to neither face nor curve |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |