AddSpatialFieldPrimitive Method (Reference)


Spatial Field Manager Add Spatial Field Primitive(Reference) Method

Creates an empty analysis results primitive associated with a reference.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int AddSpatialFieldPrimitive(
	Reference reference
)

Parameters

reference Reference
Reference pointing to the curve or face to be associated with the primitive

Return Value

Int32
Unique index of primitive for future references
Exceptions
Exception Condition
ArgumentException reference points to neither face nor curve
ArgumentNullException A non-optional argument was null
Remarks

There can be multiple primitives associated with one reference, normally they would be shown with different results. However this is justified only if they have different sets of domain points. Otherwise one primitive can be used to display values for different results.

See Also