AddEntry Method


Adds new entry to the scheme.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void AddEntry(
	ColorFillSchemeEntry entry
)
Visual Basic
Public Sub AddEntry ( _
	entry As ColorFillSchemeEntry _
)
Visual C++
public:
void AddEntry(
	ColorFillSchemeEntry^ entry
)

Remarks

To make sure that entry can be added to the scheme, call IsEntryConsistentWithScheme(ColorFillSchemeEntry) first.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException There already exists an entry with the same value in the scheme. -or- The entry value is out of range. -or- The scheme and the entry have different parameter storage type. -or- The fill pattern id is not valid for scheme.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also