Constructs the transformation by specifying the vectors and the origin.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- uVec
- Type: Autodesk.Revit.DBUV
The image of (1, 0) under OfVector(UV).
- vVec
- Type: Autodesk.Revit.DBUV
The image of (0, 1) under OfVector(UV).
- origin
- Type: Autodesk.Revit.DBUV
The image of (0, 0) under OfPoint(UV). This defines the translational part of the transform.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |