Transform2D Constructor (UV, UV, UV)


Transform 2D(UV, UV, UV) Constructor

Constructs the transformation by specifying the vectors and the origin.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Transform2D(
	UV uVec,
	UV vVec,
	UV origin
)

Parameters

uVec UV
The image of (1, 0) under OfVector(UV) .
vVec UV
The image of (0, 1) under OfVector(UV) .
origin UV
The image of (0, 0) under OfPoint(UV) . This defines the translational part of the transform.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also