CreateLogicalOfType Method


Creates a logical data object of the specified type.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static IFCData CreateLogicalOfType(
	IFCLogical value,
	string typeName
)
Visual Basic
Public Shared Function CreateLogicalOfType ( _
	value As IFCLogical, _
	typeName As String _
) As IFCData
Visual C++
public:
static IFCData^ CreateLogicalOfType(
	IFCLogical value, 
	String^ typeName
)

Parameters

value
Type: Autodesk.Revit.DB.IFCIFCLogical
The IFCLogical value.
typeName
Type: SystemString
The type name.

Return Value

The IFCData object.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also