Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pGeomArr
- Type: System.Collections.GenericIListGeometryObject
Shape of this object expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |