SetShape Method (IList(GeometryObject))


Direct Shape Set Shape(IList Geometry Object ) Method

Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetShape(
	IList<GeometryObject> pGeomArr
)

Parameters

pGeomArr IList GeometryObject
Shape of this object expressed as a collection of GeometryObjects. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Exceptions
Exception Condition
ArgumentException At least one member of pGeomArr does not satisfy DirectShape validation criteria.
ArgumentNullException A non-optional argument was null
See Also