Creates a transform that represents a rotation about the given axis at the specified point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- axis
- Type: Autodesk.Revit.DBXYZ
The rotation axis.
- angle
- Type: SystemDouble
The angle.
- origin
- Type: Autodesk.Revit.DBXYZ
The origin point.
Return Value
The new transform.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The given value for angle is not finite |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | axis has zero length. |