CreateRotationAtPoint Method


Transform Create Rotation At Point Method

Creates a transform that represents a rotation about the given axis at the specified point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Transform CreateRotationAtPoint(
	XYZ axis,
	double angle,
	XYZ origin
)

Parameters

axis XYZ
The rotation axis.
angle Double
The angle.
origin XYZ
The origin point.

Return Value

Transform
The new transform.
Exceptions
Exception Condition
ArgumentException The given value for angle is not finite
ArgumentNullException A non-optional argument was NULL
ArgumentOutOfRangeException axis has zero length.
See Also