Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryIds
- Type: System.Collections.GenericICollectionElementId
The category ids to match.
- inverted
- Type: SystemBoolean
True if the filter should match all elements which are not of the given categories.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | One or more categories was not valid for filtering. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |