ElementMulticategoryFilter Constructor (ICollection(ElementId), Boolean)


Element Multicategory Filter(ICollection Element Id , Boolean) Constructor

Constructs a new instance of a filter to find elements whose category matches any of a given set of categories, with the option to instead match elements which are not of the given categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementMulticategoryFilter(
	ICollection<ElementId> categoryIds,
	bool inverted
)

Parameters

categoryIds ICollection ElementId
The category ids to match.
inverted Boolean
True if the filter should match all elements which are not of the given categories.
Exceptions
Exception Condition
ArgumentException One or more categories was not valid for filtering.
ArgumentNullException A non-optional argument was null
See Also