ViewPrintingEventArgs Class


The event arguments used by the ViewPrinting event.

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2010

Syntax

C#
public class ViewPrintingEventArgs : RevitAPIPreDocEventArgs
Visual Basic
Public Class ViewPrintingEventArgs _
	Inherits RevitAPIPreDocEventArgs
Visual C++
public ref class ViewPrintingEventArgs : public RevitAPIPreDocEventArgs

Inheritance Hierarchy

SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPIPreEventArgs
        Autodesk.Revit.DB.EventsRevitAPIPreDocEventArgs
          Autodesk.Revit.DB.EventsViewPrintingEventArgs

See Also