View |
The event arguments used by the ViewPrinting event.

System Object
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events ViewPrintingEventArgs
System EventArgs
Autodesk.Revit.DB.Events RevitAPIEventArgs
Autodesk.Revit.DB.Events RevitAPIPreEventArgs
Autodesk.Revit.DB.Events RevitAPIPreDocEventArgs
Autodesk.Revit.DB.Events ViewPrintingEventArgs
Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ViewPrintingEventArgs type exposes the following members.

Name | Description | |
---|---|---|
![]() | Index | The index of the view being printed out of the set of all views being printed. |
![]() | TotalViews | The number of all views being printed. |
![]() | View | The view to be printed. |

Name | Description | |
---|---|---|
![]() | GetSettings | Get the print settings of the active printing session. |