Adds a new sorting/grouping field at the specified position in the list.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sortGroupField
- Type: Autodesk.Revit.DBScheduleSortGroupField
The sorting/grouping field to add.
- index
- Type: SystemInt32
The index in the list of sorting/grouping fields.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | index is not a valid insert position. |
Autodesk.Revit.ExceptionsInvalidOperationException | The resulting sorting/grouping field count would be greater than 4. |