InsertSortGroupField Method


Schedule Definition Insert Sort Group Field Method

Adds a new sorting/grouping field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void InsertSortGroupField(
	ScheduleSortGroupField sortGroupField,
	int index
)

Parameters

sortGroupField ScheduleSortGroupField
The sorting/grouping field to add.
index Int32
The index in the list of sorting/grouping fields.
Exceptions
Exception Condition
ArgumentException The field ID is not the ID of a field in this ScheduleDefinition. -or- The field cannot be used for sorting/grouping.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException index is not a valid insert position.
InvalidOperationException The resulting sorting/grouping field count would be greater than 4.
See Also