GetAssociatedPartMaker Method (Document, LinkElementId)


Gets associated PartMaker for an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static PartMaker GetAssociatedPartMaker(
	Document hostDocument,
	LinkElementId hostOrLinkElementId
)
Visual Basic
Public Shared Function GetAssociatedPartMaker ( _
	hostDocument As Document, _
	hostOrLinkElementId As LinkElementId _
) As PartMaker
Visual C++
public:
static PartMaker^ GetAssociatedPartMaker(
	Document^ hostDocument, 
	LinkElementId^ hostOrLinkElementId
)

Parameters

hostDocument
Type: Autodesk.Revit.DBDocument
The document
hostOrLinkElementId
Type: Autodesk.Revit.DBLinkElementId
The id for the element to be checked for associated Parts

Return Value

The PartMaker element that is making Parts for this element. a null reference (Nothing in Visual Basic) if there is no associated PartMaker.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also