Part |
Gets associated PartMaker for an element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static PartMaker GetAssociatedPartMaker(
Document hostDocument,
LinkElementId hostOrLinkElementId
)
Parameters
- hostDocument Document
- The document
- hostOrLinkElementId LinkElementId
- The id for the element to be checked for associated Parts
Return Value
PartMakerThe PartMaker element that is making Parts for this element. if there is no associated PartMaker.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |