SetRotation Method


Sets the rotation angle in radians for the bending detail relative to its view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public static void SetRotation(
	Element bendingDetail,
	double rotation
)
Visual Basic
Public Shared Sub SetRotation ( _
	bendingDetail As Element, _
	rotation As Double _
)
Visual C++
public:
static void SetRotation(
	Element^ bendingDetail, 
	double rotation
)

Parameters

bendingDetail
Type: Autodesk.Revit.DBElement
The bending detail for which we want to get the rotation.
rotation
Type: SystemDouble
The new rotation angle of the bending detail relative to its view.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException -or- The given value for rotation is not a number -or- The given value for rotation is not finite
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also