SetRotation Method


Rebar Bending Detail Set Rotation Method

Sets the rotation angle in radians for the bending detail relative to its view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void SetRotation(
	Element bendingDetail,
	double rotation
)

Parameters

bendingDetail Element
The bending detail for which we want to get the rotation.
rotation Double
The new rotation angle of the bending detail relative to its view.
Exceptions
Exception Condition
ArgumentException -or- The given value for rotation is not a number -or- The given value for rotation is not finite
ArgumentNullException A non-optional argument was null
See Also