Gets the line from the desired layer at the specified index.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- layer
- Type: Autodesk.Revit.DB.StructureAreaReinforcementLayerType
The layer on which the line stays.
- linePositionIndex
- Type: SystemInt32
The index of the line from the desired layer. It should be an index between 0 and (NumberOfLines-1).
Return Value
Returns the line from the desired layer at the specified index.Remarks
This method will return the line even if it isn't included.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | linePositionIndex is not in the range [ 0, NumberOfLines-1 ]. -or- A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsInapplicableDataException | The layer layer isn't active. |