Area |
Gets the line from the desired layer at the specified index.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public Line GetLineFromLayerAtIndex(
AreaReinforcementLayerType layer,
int linePositionIndex
)
Parameters
- layer AreaReinforcementLayerType
- The layer on which the line stays.
- linePositionIndex Int32
- The index of the line from the desired layer. It should be an index between 0 and (NumberOfLines-1).
Return Value
LineReturns the line from the desired layer at the specified index.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | linePositionIndex is not in the range [ 0, NumberOfLines-1 ]. -or- A value passed for an enumeration argument is not a member of that enumeration |
InapplicableDataException | The layer layer isn't active. |

This method will return the line even if it isn't included.