Creates a new LinePatternElement.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document in which to create the LinePatternElement.
- linePattern
- Type: Autodesk.Revit.DBLinePattern
The LinePattern associated to the newly created LinePatternElement.
Return Value
The newly created LinePatternElement.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The Line Pattern is not valid. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |