NewOpening Method (Element, CurveArray, Boolean)


Creates a new opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Opening NewOpening(
	Element hostElement,
	CurveArray profile,
	bool bPerpendicularFace
)
Visual Basic
Public Function NewOpening ( _
	hostElement As Element, _
	profile As CurveArray, _
	bPerpendicularFace As Boolean _
) As Opening
Visual C++
public:
Opening^ NewOpening(
	Element^ hostElement, 
	CurveArray^ profile, 
	bool bPerpendicularFace
)

Parameters

hostElement
Type: Autodesk.Revit.DBElement
Host element of the opening. Can be a roof, floor, or ceiling.
profile
Type: Autodesk.Revit.DBCurveArray
Profile of the opening.
bPerpendicularFace
Type: SystemBoolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.

Return Value

If successful, an Opening object is returned.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the host element does not exist in the given document.

See Also