NewOpening Method (Element, CurveArray, Boolean)


Document New Opening(Element, Curve Array, Boolean) Method

Creates a new opening in a roof, floor and ceiling.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Opening NewOpening(
	Element hostElement,
	CurveArray profile,
	bool bPerpendicularFace
)

Parameters

hostElement Element
Host element of the opening. Can be a roof, floor, or ceiling.
profile CurveArray
Profile of the opening.
bPerpendicularFace Boolean
True if the profile is cut perpendicular to the intersecting face of the host. False if the profile is cut vertically.

Return Value

Opening
If successful, an Opening object is returned.
Exceptions
Exception Condition
ArgumentException Thrown if the host element does not exist in the given document.
See Also