FilteredElementCollector Constructor (Document, ICollection(ElementId))


Constructs a new FilteredElementCollector that will search and filter a specified set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public FilteredElementCollector(
	Document document,
	ICollection<ElementId> elementIds
)
Visual Basic
Public Sub New ( _
	document As Document, _
	elementIds As ICollection(Of ElementId) _
)
Visual C++
public:
FilteredElementCollector(
	Document^ document, 
	ICollection<ElementId^>^ elementIds
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document that owns the elements matching the element ids.
elementIds
Type: System.Collections.GenericICollectionElementId
The input set of element ids.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input collection of ids was empty, or its contents were not valid for iteration.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also