FilteredElementCollector Constructor (Document, ICollection(ElementId))


Filtered Element Collector(Document, ICollection Element Id ) Constructor

Constructs a new FilteredElementCollector that will search and filter a specified set of elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FilteredElementCollector(
	Document document,
	ICollection<ElementId> elementIds
)

Parameters

document Document
The document that owns the elements matching the element ids.
elementIds ICollection ElementId
The input set of element ids.
Exceptions
Exception Condition
ArgumentException The input collection of ids was empty, or its contents were not valid for iteration.
ArgumentNullException A non-optional argument was null
See Also