CompoundStructureLayer Constructor (Double, MaterialFunctionAssignment, ElementId)


Creates a default compound structure layer based on the given width, function and material element id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public CompoundStructureLayer(
	double width,
	MaterialFunctionAssignment function,
	ElementId materialId
)
Visual Basic
Public Sub New ( _
	width As Double, _
	function As MaterialFunctionAssignment, _
	materialId As ElementId _
)
Visual C++
public:
CompoundStructureLayer(
	double width, 
	MaterialFunctionAssignment function, 
	ElementId^ materialId
)

Parameters

width
Type: SystemDouble
The width of the layer.
function
Type: Autodesk.Revit.DBMaterialFunctionAssignment
The function of the layer.
materialId
Type: Autodesk.Revit.DBElementId
The material element id of the layer.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also