CompoundStructureLayer Constructor (Double, MaterialFunctionAssignment, ElementId)


Compound Structure Layer(Double, Material Function Assignment, Element Id) Constructor

Creates a default compound structure layer based on the given width, function and material element id. The priority is initialized with 999.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public CompoundStructureLayer(
	double width,
	MaterialFunctionAssignment function,
	ElementId materialId
)

Parameters

width Double
The width of the layer.
function MaterialFunctionAssignment
The function of the layer.
materialId ElementId
The material element id of the layer.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also