Adds a regular field at the specified position in the list.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fieldType
- Type: Autodesk.Revit.DBScheduleFieldType
The type of data displayed by the field.
- index
- Type: SystemInt32
The index in the list of fields.
Return Value
The new field.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. -or- The fieldType can't be CustomField. To add a CustomField, you should create a Schedulable field and add it. |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | index is not a valid insert position. -or- A value passed for an enumeration argument is not a member of that enumeration |