InsertField Method (ScheduleFieldType, Int32)


Schedule Definition Insert Field(Schedule Field Type, Int 32) Method

Adds a regular field at the specified position in the list.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ScheduleField InsertField(
	ScheduleFieldType fieldType,
	int index
)

Parameters

fieldType ScheduleFieldType
The type of data displayed by the field.
index Int32
The index in the list of fields.

Return Value

ScheduleField
The new field.
Exceptions
Exception Condition
ArgumentException The field specified by fieldType may not included in this ScheduleDefinition. -or- The field specified by fieldType is already included in this ScheduleDefinition. -or- The fieldType can't be CustomField. To add a CustomField, you should create a Schedulable field and add it.
ArgumentOutOfRangeException index is not a valid insert position. -or- A value passed for an enumeration argument is not a member of that enumeration
See Also