IsCuttingElementInJoin Method


Determines whether the first of two joined elements is cutting the second element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static bool IsCuttingElementInJoin(
	Document document,
	Element firstElement,
	Element secondElement
)
Visual Basic
Public Shared Function IsCuttingElementInJoin ( _
	document As Document, _
	firstElement As Element, _
	secondElement As Element _
) As Boolean
Visual C++
public:
static bool IsCuttingElementInJoin(
	Document^ document, 
	Element^ firstElement, 
	Element^ secondElement
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document containing the two elements.
firstElement
Type: Autodesk.Revit.DBElement
The first element.
secondElement
Type: Autodesk.Revit.DBElement
The second element.

Return Value

True if the secondElement is cut by the firstElement, false if the secondElement is cut by the firstElement.

Remarks

This functionality is not available for family documents.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also