Join |
Determines whether the first of two joined elements is cutting the second element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsCuttingElementInJoin(
Document document,
Element firstElement,
Element secondElement
)
Parameters
- document Document
- The document containing the two elements.
- firstElement Element
- The first element.
- secondElement Element
- The second element.
Return Value
BooleanTrue if the secondElement is cut by the firstElement, false if the secondElement is cut by the firstElement.

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. |
ArgumentNullException | A non-optional argument was null |

This functionality is not available for family documents.