SetFlags Method (IList(Int32))


Independently sets the flags associated to all measurements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void SetFlags(
	IList<int> flags
)
Visual Basic
Public Sub SetFlags ( _
	flags As IList(Of Integer) _
)
Visual C++
public:
void SetFlags(
	IList<int>^ flags
)

Parameters

flags
Type: System.Collections.GenericIListInt32
An array of flags values. Each member corresponds to a measurement. Flags values are defined in the enumerated class ValueAtPointFlags and are combined into the int value. Number of measurements is set at creation of SpatialFieldManager in method createSpatialFieldManager.

Remarks

If you set the array of flags to only contain one value, this flags value will apply to all measurements

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also