SetFlags Method (IList(Int32))


Value At Point Base Set Flags(IList Int 32 ) Method

Independently sets the flags associated to all measurements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetFlags(
	IList<int> flags
)

Parameters

flags IList Int32
An array of flags values. Each member corresponds to a measurement. Flags values are defined in the enumerated class ValueAtPointFlags and are combined into the int value. Number of measurements is set at creation of SpatialFieldManager in method createSpatialFieldManager.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If you set the array of flags to only contain one value, this flags value will apply to all measurements
See Also