Creates a RevitLinkOptions object, specifying relative or absolute path type, and the desired workset configuration.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- relative
- Type: SystemBoolean
True if the link should use a relative path. False if it should use an absolute path.
- config
- Type: Autodesk.Revit.DBWorksetConfiguration
A WorksetConfiguration object specifying the worksets to open when creating the link. Leave as a null reference (Nothing in Visual Basic) if the file is not workshared. Optionally, this may also be a null reference (Nothing in Visual Basic) for a workshared file, in which case Revit will open all worksets.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |