Adds the two specified 2-D vectors and returns the result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- left
- Type: Autodesk.Revit.DBUV
The first vector.
- right
- Type: Autodesk.Revit.DBUV
The second vector.
Return Value
The 2-D vector equal to the sum of the two source vectors.Remarks
The added vector is obtained by adding each coordinate of the right vector to the corresponding coordinate of the left vector.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when left or right is a null reference (Nothing in Visual Basic). |