Checks that the parameters of the given ElementFilter (representing a combination of rules) are valid for the given set of categories.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDocument
- Type: Autodesk.Revit.DBDocument
The document containing the filter, categories, and parameters involved in this validation.
- categories
- Type: System.Collections.GenericICollectionElementId
The set of categories against which to check the rule parameters.
- elementFilter
- Type: Autodesk.Revit.DBElementFilter
The ElementFilter representing the combination of rules to check.
Return Value
True if all the parameters of the given rules are valid for this filter, otherwise false.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |